Important security update for Git and Mercurial (CVE-2014-9390)

A critical client-side vulnerability was discovered in both Git and Mercurial.